summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-04-06 00:52:54 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-08 14:04:46 +0200
commit5b9f07bb072d134f0877d89385538c0c6e743102 (patch)
tree00128471b3d2bf86c64b2ecb7e1296f1c6e462da /gnu
parent226e7e0437292710aec6e18c15d6521292b280fd (diff)
gnu: Add emacs-flymake-popon.
* gnu/packages/emacs-xyz.scm (emacs-flymake-popon): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 84642bae71..8efd1b0029 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2305,6 +2305,29 @@ and help selectively enable or disable diagnostic functions based on major
modes.")
(license license:expat)))
+(define-public emacs-flymake-popon
+ (package
+ (name "emacs-flymake-popon")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/akib/emacs-flymake-popon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ljqnnl5k2f62ilahilx0ldv0spjp9hpgyikd4py1348flzq4k31"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-popon
+ emacs-posframe))
+ (home-page "https://codeberg.org/akib/emacs-flymake-popon")
+ (synopsis "Flymake diagnostics on cursor hover")
+ (description "This package shows Flymake diagnostics on cursor hover.")
+ (license license:gpl3+)))
+
(define-public emacs-flymake-flycheck
(package
(name "emacs-flymake-flycheck")