summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-16 07:45:02 +0300
commit5cf8b0a46e2597ee8e4558e9be6c7af2cfcc0680 (patch)
tree5102b910800bb3befa9a70fa652783d199928512 /gnu
parent637bff317049c51c93a7cf1ac511519cb86f8243 (diff)
gnu: poppler: Fix cross-compiling.
* gnu/packages/pdf.scm (poppler)[native-inputs]: When cross-compiling add pkg-config-for-build.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 029eafc010..ae47d97848 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -341,10 +341,14 @@ please install the @code{flyer-composer-gui} package.")))
;; different solution to the circular dependency mentioned above.
(list glib))
(native-inputs
+ (append
(list pkg-config
`(,glib "bin") ; glib-mkenums, etc.
gobject-introspection
- python))
+ python)
+ (if (%current-target-system)
+ (list pkg-config-for-build)
+ '())))
(arguments
(list
;; The Poppler test suite needs to be downloaded separately and contains