summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-08 11:35:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-08 11:53:00 +0200
commit5ee51394d727854b0b2cc6199929fa4292deb446 (patch)
treef045a0f2a472c61cee61800d981030c3ae908252 /gnu
parentca8fcca4566df922e45a24d4a30c57fad7813924 (diff)
gnu: tracker: Honor #:test-options keyword.
* gnu/packages/gnome.scm (tracker)[arguments]: Adjust custom 'check phase to honor the #:test-options keyword.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e41c3754e4..dfc092ce33 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2015-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
@@ -9637,12 +9637,12 @@ easy, safe, and automatic.")
(("/etc/asciidoc[^']+")
file)))))
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? test-options #:allow-other-keys)
(when tests?
;; Some tests expect to write to $HOME.
(setenv "HOME" "/tmp")
- (invoke "dbus-run-session" "--" "meson" "test"
- "--print-errorlogs")))))))
+ (apply invoke "dbus-run-session" "--" "meson" "test"
+ "--print-errorlogs" test-options)))))))
(native-inputs
(list gettext-minimal
`(,glib "bin")