summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 14:16:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:42 +0100
commit5f578c37429edc0e6c50f40cb1fb2467eba49e5d (patch)
tree5f025ddb469491c206dbc81828886fbea5ef4366 /gnu
parent584e77abd541ac5e0227639597241f3f28d139b6 (diff)
gnu: Add go-github-com-hashicorp-golang-lru.
* gnu/packages/golang-xyz.scm go-github-com-hashicorp-golang-lru-v2, go-github-com-hashicorp-golang-lru): New variables. Change-Id: Id8de7d211e7a8fc4b257b0d2155ec9f4ed3cc3b9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5263d08d73..3bdd43edc6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1417,6 +1417,51 @@ a collection of versions properly, handles prerelease/beta versions, can
increment versions.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-golang-lru
+ (package
+ (name "go-github-com-hashicorp-golang-lru")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/golang-lru")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13q3mdlr4hb2cxa5k4ccpz1gg4swrmkxm7h3brq3xsawidpbjbyb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/golang-lru"))
+ (home-page "https://github.com/hashicorp/golang-lru")
+ (synopsis "Golang LRU cache")
+ (description
+ "@code{lru} is a package which implements a fixed-size thread safe
+@acronym{Least recently used,LRU} cache. It is based on the cache in
+Groupcache.")
+ (license license:mpl2.0)))
+
+(define-public go-github-com-hashicorp-golang-lru-v2
+ (package
+ (inherit go-github-com-hashicorp-golang-lru)
+ (name "go-github-com-hashicorp-golang-lru-v2")
+ (version "2.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/golang-lru")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lb2ylv2bz6lsqhn6c2hsafjjcx0hsdbah6arhb778g3xbkpgvf3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/hashicorp/golang-lru/v2"))))
+
(define-public go-github-com-hashicorp-hcl
(package
(name "go-github-com-hashicorp-hcl")