summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:11 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:19 -0500
commit61b29e1cf2a2093ae5f4a14685bdc993552ff041 (patch)
treef9906916a7178eefa0603cd975afaa2687770715 /gnu
parent157369092adae975e2cd5f8f6e68f234e685900f (diff)
gnu: go-github-com-valyala-fasthttp: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-valyala-fasthttp): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I60676c0204e198c6050724efa5410c5b695f88fb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm41
-rw-r--r--gnu/packages/golang.scm40
2 files changed, 41 insertions, 40 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 352c831e41..f59415452f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -760,6 +761,46 @@ an interface to implement any other minifier.")
"This package contains several lexers and parsers written in Go.")
(license license:expat)))
+(define-public go-github-com-valyala-fasthttp
+ (package
+ (name "go-github-com-valyala-fasthttp")
+ (version "1.39.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/valyala/fasthttp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12qwx0yk7wjj25v4fswgmj28r69gk94kqdmzavca8k9f0yznniz1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/valyala/fasthttp"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; Tests hang forever with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
+ (propagated-inputs
+ (list go-github-com-andybalholm-brotli
+ go-github-com-klauspost-compress
+ go-github-com-valyala-bytebufferpool
+ go-github-com-valyala-tcplisten
+ go-golang-org-x-crypto
+ go-golang-org-x-net
+ go-golang-org-x-sys))
+ (home-page "https://github.com/valyala/fasthttp")
+ (synopsis "Provides fast HTTP server and client API")
+ (description
+ "This package provides a Go module @code{fasthttp} which may be used as
+replacement for native @code{net/http} module.")
+ (license license:expat)))
+
(define-public go-gopkg-in-square-go-jose-v2
(package
(name "go-gopkg-in-square-go-jose-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1a02f66ac8..e79179679c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11304,46 +11304,6 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
anti-fragmentation protection.")
(license license:expat)))
-(define-public go-github-com-valyala-fasthttp
- (package
- (name "go-github-com-valyala-fasthttp")
- (version "1.39.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/valyala/fasthttp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12qwx0yk7wjj25v4fswgmj28r69gk94kqdmzavca8k9f0yznniz1"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/valyala/fasthttp"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; Tests hang forever with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (propagated-inputs
- (list go-golang-org-x-sys
- go-golang-org-x-net
- go-golang-org-x-crypto
- go-github-com-valyala-tcplisten
- go-github-com-valyala-bytebufferpool
- go-github-com-klauspost-compress
- go-github-com-andybalholm-brotli))
- (home-page "https://github.com/valyala/fasthttp")
- (synopsis "Provides fast HTTP server and client API")
- (description
- "This package provides a Go module @code{fasthttp} which may be used as
-replacement for native @code{net/http} module.")
- (license license:expat)))
-
(define-public go-github-com-valyala-tcplisten
(package
(name "go-github-com-valyala-tcplisten")