summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-06 13:42:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-06 14:00:21 +0200
commit6211ecfec804f16ab99382ca3d639b2d5d4a62d5 (patch)
tree57d291097b27e8c6601e51e79fe2535c11a345d0 /gnu
parent5bd7de4cede4d529bf4477d87dd82517d7280f91 (diff)
gnu: Add hh-suite.
* gnu/packages/bioinformatics.scm (hh-suite): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 285343f632..525509f56d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15839,6 +15839,35 @@ workflows from concise descriptions in ccwl. It is implemented as an
language.")
(license license:gpl3+)))
+(define-public hh-suite
+ (package
+ (name "hh-suite")
+ (version "3.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/soedinglab/hh-suite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bcmzg0ii6nkda2xm5jdddbwkgsag7k38j20af0c9chr2mbxwx4d"))
+ (modules '((guix build utils)))
+ (snippet
+ '(delete-file-recursively "lib/simde"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #false)) ;no test target
+ (inputs
+ (list openmpi simde))
+ (native-inputs
+ (list perl pkg-config xxd))
+ (home-page "https://bmcbioinformatics.biomedcentral.com/articles/10.1186/s12859-019-3019-7")
+ (synopsis "Remote protein homology detection suite")
+ (description "The HH-suite is a software package for sensitive protein sequence searching
+based on the pairwise alignment of hidden Markov models (HMMs).")
+ (license license:gpl3+)))
+
(define-public wfmash
(package
(name "wfmash")