summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-18 10:43:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-18 20:56:59 +0000
commit662ae5eac2753d8a0a662738c3b7b64d77597c08 (patch)
treeb814766c474e2c56de19fce934107e3ffcf79600 /gnu
parent3e3975275bbab84d58f7740e9680b265769aa580 (diff)
gnu: python-plotnine: Fix build.
* gnu/packages/python-science.scm (python-plotnine): Fix build. [arguments]<#:test-flags>: Add test_custom_shape to ignored tests. Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c57fd1f23c..b13d2ca0b2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1741,8 +1741,6 @@ aggregated sum and more.")
(define-public python-plotnine
(package
(name "python-plotnine")
- ;; XXX Version 0.12.x exists, but we can't build it because we're still at
- ;; matplotlib 3.5. We'd need at least 3.6.
(version "0.10.1")
(source (origin
(method git-fetch)
@@ -1757,6 +1755,7 @@ aggregated sum and more.")
(arguments
(list
#:test-flags
+ ;; XXX: Check for any new failing tests during next update cycle.
;; These all fail because the images are considered to be too different,
;; though they really do look fine.
'(list "-k" (string-append
@@ -1774,6 +1773,7 @@ aggregated sum and more.")
"test_continuous_x_fullrange"
"test_coord_trans_backtransforms"
"test_coord_trans_se_false"
+ "test_custom_shape"
"test_datetime_scale_limits"
"test_dir_v_ncol"
"test_discrete_x"