summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-18 20:52:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-18 20:52:53 +0300
commit6744ec2f3535a720a4b47425f1b6f42aaa31a182 (patch)
treeb66afadb183ecf6daeef8c10141866db17986c06 /gnu
parente4087930f3ad60918689be5f4bca4ce3e22429f5 (diff)
gnu: gst-plugins-bad: Fix test suite on riscv64-linux.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Adjust custom 'adjust-tests phase to help tests pass on riscv64-linux.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8971c11479..075f424560 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -799,6 +799,14 @@ model to base your own plug-in on, here it is.")
;; This test is flaky on at least some architectures.
;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ #$@(if (target-riscv64?)
+ `((("'elements/camerabin\\.c'\\].*],")
+ "'elements/camerabin.c'], true, ],")
+ (("'elements/viewfinderbin\\.c'\\].*],")
+ "'elements/viewfinderbin.c'], true, ],"))
+ '())
+
+ ;; This substitution is no longer effective and can be removed.
#$@(if (member (%current-system)
'("i686-linux" "aarch64-linux" "riscv64-linux"))
`((("'elements/camerabin\\.c'\\]\\],")