summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commit6984151a834d1d27f0b35c250bd57273783f7d5f (patch)
tree50577f42c4672f58ca72e6a4ccf49fd4dcd23534 /gnu
parentd23ced7cc1d59af4bf8cac28e332ca29bc7b93e1 (diff)
gnu: cryfs: Update to 0.11.4.
* gnu/packages/crypto.scm (cryfs): Update to 0.11.4. [arguments]: Remove obsolete phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 91acedbc97..0f1e70f4dc 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1479,7 +1479,7 @@ non-encrypted files.")
(define-public cryfs
(package
(name "cryfs")
- (version "0.11.3")
+ (version "0.11.4")
(source
(origin
(method url-fetch)
@@ -1487,7 +1487,7 @@ non-encrypted files.")
"https://github.com/cryfs/cryfs/releases/download/"
version "/cryfs-" version ".tar.xz"))
(sha256
- (base32 "1h41dhdfk2nll0vx5i66mgrdalv6kccwq5yx99gridywxw6qxxhq"))))
+ (base32 "0a48qijfrd02ianp19x3kz24w1pgigmlxdr5nks0gag7z5b2s7m7"))))
(build-system cmake-build-system)
(arguments
'(#:modules ((guix build cmake-build-system)
@@ -1514,14 +1514,7 @@ non-encrypted files.")
(when tests?
(substitute* "CMakeLists.txt"
(("option.BUILD_TESTING .build test cases. OFF.")
- "option(BUILD_TESTING \"build test cases\" ON)")))
- ;; work around a missing import fixed upstream in boost 1.78
- ;; See https://github.com/boostorg/process/issues/213
- (substitute* (find-files "." "subprocess.cpp$")
- (("#include <boost/process.hpp>.*" line)
- (string-append
- "#include <algorithm>\n"
- line)))))
+ "option(BUILD_TESTING \"build test cases\" ON)")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?