summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-17 19:12:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-09 15:45:59 +0200
commit6c39886a808e5d35bbb8c8311de374222acb2d8b (patch)
treebed3b79923b8d9f2567d68023e85d489de1d7552 /gnu
parent35a37efbfd77faefa1e46e5745737949f055adbe (diff)
gnu: Add newlib-arm-none-eabi.
* gnu/packages/embedded.scm (newlib-arm-none-eabi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/embedded.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 863fc4cec7..cb4ccdf25a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -96,3 +96,46 @@
(search-path-specification
(variable "CROSS_LIBRARY_PATH")
(files '("arm-none-eabi/lib"))))))))
+
+(define-public newlib-arm-none-eabi
+ (package
+ (name "newlib")
+ (version "2.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://sourceware.org/pub/newlib/newlib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01i7qllwicf05vsvh39qj7qp5fdifpvvky0x95hjq39mbqiksnsl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:out-of-source? #t
+ ;; The configure flags are identical to the flags used by the "GCC ARM
+ ;; embedded" project.
+ #:configure-flags '("--target=arm-none-eabi"
+ "--enable-newlib-io-long-long"
+ "--enable-newlib-register-fini"
+ "--disable-newlib-supplied-syscalls"
+ "--disable-nls")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-references-to-/bin/sh
+ (lambda _
+ (substitute* '("libgloss/arm/cpu-init/Makefile.in"
+ "libgloss/arm/Makefile.in"
+ "libgloss/libnosys/Makefile.in"
+ "libgloss/Makefile.in")
+ (("/bin/sh") (which "sh")))
+ #t)))))
+ (native-inputs
+ `(("xbinutils" ,(cross-binutils "arm-none-eabi"))
+ ("xgcc" ,gcc-arm-none-eabi-4.9)
+ ("texinfo" ,texinfo)))
+ (home-page "http://www.sourceware.org/newlib/")
+ (synopsis "C library for use on embedded systems")
+ (description "Newlib is a C library intended for use on embedded
+systems. It is a conglomeration of several library parts that are easily
+usable on embedded products.")
+ (license (license:non-copyleft
+ "https://www.sourceware.org/newlib/COPYING.NEWLIB"))))