summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:28:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:34 +0200
commit6cb6915adbe693faac325bd2c47a3252aecb0542 (patch)
tree602a5ad262790ceb488de3b4e03b438826c32d96 /gnu
parentd014c720636002189a6c22dd4d0ce820c8c89bfa (diff)
gnu: Add texlive-abc.
* gnu/packages/tex.scm (texlive-abc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b93e07a0c5..e88eef1158 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1269,6 +1269,28 @@ a Marathi journal, with LaTeX.")
(license:fsf-free "file://doc/latex/aalok/README.txt")
license:fdl1.3+))))
+(define-public texlive-abc
+ (package
+ (name "texlive-abc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/abc/" "source/latex/abc/"
+ "tex/latex/abc/")
+ (base32
+ "1vywrv35h65gkxipc7d26k32r04fk61kfkkk9bj3zsmxsw1v3r8d")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/abc")
+ (synopsis "Support ABC music notation in LaTeX")
+ (description
+ "The abc package lets you include lines of music written in the ABC Plus
+language. The package will then employ the @code{\\write18} facility to
+convert your notation to PostScript (using the established utility
+@command{abcm2ps}) and hence to the format needed for inclusion in your
+document.")
+ (license license:lppl1.2+)))
+
(define-public texlive-accents
(package
(name "texlive-accents")