summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-15 18:08:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-15 18:09:46 +0200
commit6e1215fb9c03ccb4a2d4440990aee5a66a935268 (patch)
tree0e930bbc3ae5fb9ceaab0878ea226dfea1ae4507 /gnu
parent7dc206c8f8ec742736a92e41da899249744a3fdd (diff)
gnu: Add r-plumber.
* gnu/packages/cran.scm (r-plumber): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b68af1efb7..ba81580258 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2505,6 +2505,40 @@ does not use formula input or special syntax, but can be used in combination
with default R plot functions.")
(license license:gpl2+)))
+(define-public r-plumber
+ (package
+ (name "r-plumber")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "plumber" version))
+ (sha256
+ (base32
+ "1k0y7ylc8bld16imn86g0i0dmxmr3kmh9ax4ys0yrxqzrvji7z3g"))))
+ (properties `((upstream-name . "plumber")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-crayon
+ r-ellipsis
+ r-httpuv
+ r-jsonlite
+ r-lifecycle
+ r-magrittr
+ r-mime
+ r-promises
+ r-r6
+ r-rlang
+ r-sodium
+ r-stringi
+ r-swagger
+ r-webutils))
+ (home-page "https://www.rplumber.io")
+ (synopsis "API generator for R")
+ (description
+ "This package gives you the ability to automatically generate and serve
+an HTTP API from R functions using the annotations in the R documentation
+around your functions.")
+ (license license:expat)))
+
(define-public r-polychrome
(package
(name "r-polychrome")