summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:24:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:32 +0200
commit70686b28088a83e852957c30e35c2c26ca9c95d7 (patch)
treee660af1e00c6e1ad5468498c558b705a0bcf66e4 /gnu
parentd26e61638162b329bb2d37d3ffd9eebe7f410777 (diff)
gnu: Add texlive-sudokubundle.
* gnu/packages/tex.scm (texlive-sudokubundle): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 595e692164..ae8461577a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13744,6 +13744,32 @@ using the @code{\\text@{@}} command from the @code{amstext} package.")
grids.")
(license license:lppl)))
+(define-public texlive-sudokubundle
+ (package
+ (name "texlive-sudokubundle")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/sudokubundle/"
+ "source/latex/sudokubundle/"
+ "tex/latex/sudokubundle/")
+ (base32
+ "1swsx8r0chgxv8h27syj4h5cf7lnj6mxvwhhzixbkjg6scrvd8kw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/sudokubundle")
+ (synopsis "A set of sudoku-related packages")
+ (description
+ "The bundle provides three packages: @code{printsudoku}, which provides
+a command @code{\\sudoku} whose argument is the name of a file containing
+a puzzle specification; @code{solvesudoku}, which attempts to find a solution
+to the puzzle in the file named in the argument; and @code{createsudoku},
+which uses the @code{random} package to generate a puzzle according to a bunch
+of parameters that the user sets via macros.
+
+The bundle comes with a set of ready-prepared puzzle files.")
+ (license license:lppl)))
+
(define-public texlive-susy
(package
(name "texlive-susy")