summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-03 12:04:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:24 +0300
commit70a7011ed14979aca74567c14f17bb7451c7f831 (patch)
treed0de5f74f5e930cdd3d1d6fc12bcc64b16ca9929 /gnu
parent4845e65ea32bc5ead95e4127abfdb85887e7ebb0 (diff)
gnu: rust-dunce-1: Update to 1.0.4.
* gnu/packages/crates-io.scm (rust-dunce-1): Update to 1.0.4. [arguments]: Don't skip build. [license]: Update license field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8ce13612bd..72d35a49f6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21118,16 +21118,15 @@ Rust.")
(define-public rust-dunce-1
(package
(name "rust-dunce")
- (version "1.0.1")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
(uri (crate-uri "dunce" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1d7f7wg83i1by16rxc1fdipi872nvkzjnmzaaggh2h8cgi51qr5j"))))
+ (base32 "0fqcbwfclldbknmawi69l6zyncaiqzxkpbybcb2cc7jmlxnqrkjn"))))
(build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
(home-page "https://gitlab.com/kornelski/dunce")
(synopsis "Normalize Windows paths to the most compatible format")
(description
@@ -21136,7 +21135,7 @@ whenever possible, but leaves UNC paths as-is when they can't be unambiguously
expressed in a simpler way. This allows legacy programs to access all paths
they can possibly access, and doesn't break any paths for UNC-aware
programs.")
- (license license:cc0)))
+ (license (list license:cc0 license:expat-0 license:asl2.0))))
(define-public rust-dyn-clone-1
(package