summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 10:16:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 12:56:39 +0200
commit722a8b2296e32f7ef510bf877c36d30b2ef621b5 (patch)
treee0006be704417c82a5f40a1e6058022cadfd91e4 /gnu
parent5107a8a1a394fef300c2d98d36b1bd92122ecf39 (diff)
gnu: Add bpp-seq-omics.
* gnu/packages/bioinformatics.scm (bpp-seq-omics): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ad61b979dd..576af31ae6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2321,6 +2321,28 @@ analysis, phylogenetics, molecular evolution and population genetics. This
library provides sequence-related modules.")
(license license:cecill-c)))
+(define-public bpp-seq-omics
+ (package
+ (name "bpp-seq-omics")
+ (version "2.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioPP/bpp-seq-omics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sc2xdfnfp5a6qihplp49rgrqmj89898avfy9bqaq1g2fajppgjj"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list bpp-core bpp-seq))
+ (home-page "https://github.com/BioPP/bpp-seq-omics")
+ (synopsis "Bio++ sequence library genomics components")
+ (description
+ "This library contains the genomics components of the Bio++ sequence library.
+It is part of the Bio++ project.")
+ (license license:cecill)))
+
(define-public bppsuite
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.