summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:05:49 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:09:05 -0400
commit7330256b4c36d5446b77c4b9824c72993b7a4a75 (patch)
tree4b3ee9f508c765d9d09bd2d90d2ca65939d82a0f /gnu
parented1b2d0a86a0a62d8d843f06669a5f072482c37e (diff)
Partial revert d3a0869e9b667d563e7e877c93f30a70896c5831.
This reconciles the changes from d3a0869e9b667d563e7e877c93f30a70896c5831 and a2ee092ff2f3c37be0d47fc19e6cd7aa84bd9490. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docbook.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index cbd1fe2f14..06d7e014dc 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -582,6 +582,30 @@ the in DocBook SGML DTDs.")
(base32
"0yd09nypswy3q4scri1dg7dr99d7gd6r2dwx0xm81l9f4y32gs0n"))))
(build-system python-build-system)
+ (arguments
+ (list
+ ;; Using setuptools causes an invalid "package_base" path in
+ ;; out/bin/.dblatex-real due to a missing leading '/'. This is caused
+ ;; by dblatex's setup.py stripping the root path when creating the
+ ;; script (dblatex's setup.py still uses distutils and thus has to
+ ;; create the script by itself. The feature for creating scripts is one
+ ;; of setuptools' features, see:
+ ;; https://lists.gnu.org/archive/html/guix-devel/2016-12/msg00030.html).
+ #:use-setuptools? #f
+ #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'wrap 'set-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((path (map (lambda (x)
+ (string-append (assoc-ref inputs x)
+ "/bin"))
+ (list "libxslt"
+ "imagemagick" "inkscape"
+ "texlive-updmap.cfg"))))
+ ;; dblatex executes helper programs at runtime.
+ (wrap-program (string-append #$output "/bin/dblatex")
+ `("PATH" ":" prefix ,path))))))))
;; TODO: Add fig2dev for fig2dev utility.
(inputs
(list (texlive-updmap.cfg (list texlive-anysize