summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 15:27:49 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-29 12:13:06 +0100
commit73a20f8aec2de8b86d5ac2eacf661ca6260f55f6 (patch)
treee64605db94460216ea79a66726500bc3fbab29a9 /gnu
parent8ec2b1efacd0d9b4b44ae3ebe774137c4d9002b3 (diff)
gnu: Add texlive-mfware-bin.
* gnu/packages/tex.scm (texlive-mfware-bin): New variable. (texlive-mfware)[propagated-inputs]: Add TEXLIVE-MFWARE-BIN. (texlive-cm)[arguments]<#:phases>: Call `gftopk' binary from TEXLIVE-MFWARE-BIN. [native-inputs]: Add TEXLIVE-MFWARE-BIN. Change-Id: Ic1aaa377fd7137794ff7705a42a4cb69e48f74f5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 33 insertions, 3 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d4913e4755..d62583cd25 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -39772,17 +39772,21 @@ part of the cite bundle of the author's citation-related packages.")
(let* ((cwd (getcwd))
(pkdir
(string-append cwd "/fonts/pk/ljfour/public/cm/dpi600"))
- (build-dir (string-append cwd "/build")))
+ (build-dir (string-append cwd "/build"))
+ (gftopk
+ (string-append
+ #$(this-package-native-input "texlive-mfware-bin")
+ "/bin/gftopk")))
(with-directory-excursion "fonts/source/public/cm/"
(mkdir-p pkdir)
(for-each
(lambda (font)
(let ((font-name (basename font ".mf")))
- (invoke "gftopk"
+ (invoke gftopk
(string-append build-dir "/" font-name ".600gf")
(string-append pkdir "/" font-name ".pk"))))
(find-files "." "cm(.*[0-9]+.*|inch)\\.mf$")))))))))
- (native-inputs (list texlive-metafont))
+ (native-inputs (list texlive-metafont texlive-mfware-bin))
(home-page "https://ctan.org/pkg/cm")
(synopsis "Computer Modern fonts for TeX")
(description
@@ -40828,6 +40832,7 @@ Taco Hoekwater.")
"0l0xy2zl7yzb14wbzsg4sz5bdj22ggqlsw54d0yrm430wlr1s6sd")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-mfware-bin))
(home-page "https://ctan.org/pkg/mfware")
(synopsis "Supporting tools for use with Metafont")
(description
@@ -40835,6 +40840,31 @@ Taco Hoekwater.")
processing the output of Metafont.")
(license license:public-domain)))
+(define-public texlive-mfware-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-mfware-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(delete "--enable-web2c" #$flags))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (let ((bin (string-append #$output "/bin"))
+ (files '("gftodvi" "gftopk" "gftype" "mft" "pktogf"
+ "pktype")))
+ (for-each (lambda (f) (invoke "make" f)) files)
+ (for-each (lambda (f) (install-file f bin)) files)))))))))
+ (native-inputs (list pkg-config))
+ (home-page (package-home-page texlive-mfware))
+ (synopsis "Binaries for @code{texlive-mfware}")
+ (description
+ "This package provides the binaries for @code{texlive-mfware}.")
+ (license (package-license texlive-mfware))))
+
(define-public texlive-milsymb
(package
(name "texlive-milsymb")