summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-03-02 23:31:09 +0100
committerLeo Famulari <leo@famulari.name>2017-03-15 17:17:06 -0400
commit781d3b070cab20caf33a2b9ac8d48b3221622fab (patch)
tree7c42bf45e7919a825f1e19510262e3c204808228 /gnu
parent13292ee57077be8c77aa379ea4e5f85f1e5358ef (diff)
gnu: Add libstrophe.
* gnu/packages/messaging.scm (libstrophe): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c14fb72386..493b18b666 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1258,4 +1258,39 @@ manual SSL certificate verification.")
;; Dual licensed.
(license (list license:gpl3+ license:x11))))
+(define-public libstrophe
+ (package
+ (name "libstrophe")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/strophe/libstrophe/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hzwdax4nsz0fncf5bjfza0cn0lc6xsf38y569ql1gg5hvwr6169"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "./bootstrap.sh")))))))
+ (inputs
+ `(("expat" ,expat)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "C library for writing XMPP clients")
+ (description "Libstrophe is a minimal XMPP library written in C. It has
+almost no external dependencies, only an XML parsing library (expat or libxml
+are both supported).")
+ (home-page "http://strophe.im/libstrophe")
+ ;; Dual licensed.
+ (license (list license:gpl3+ license:x11))))
+
;;; messaging.scm ends here