summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-30 15:31:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-30 15:31:07 +0100
commit788657b62d0bf76015ccf0155a0bf2d3cfd9994a (patch)
tree07c6bb41786dc9649ecb4cc37d81f3a8254e6f71 /gnu
parenta4e75305e29318f19cf7e23e21778006d3f64e30 (diff)
gnu: r-antiword: Update to 1.3.3.
* gnu/packages/cran.scm (r-antiword): Update to 1.3.3. [properties]: Tell updater not to remove "antiword" input. [arguments]: Use G-expression. Change-Id: Ifdbf80f546b0ab3abfc3b8002ba01b46c9105a1c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0685049641..8ef9c923c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38396,28 +38396,31 @@ or into raw bitmap vectors for further processing in R.")
(define-public r-antiword
(package
(name "r-antiword")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "antiword" version))
(sha256
(base32
- "1z1xfr2pb1k1k2v65l4bby4smkqg20i22jkvqzw4y2487gndx4cx"))
+ "1cc355sldhsbpx9wl5hkx0ydkgd3racxhkrriv58yw5xbb3b18ff"))
(modules '((guix build utils)))
;; unvendor libantiword
(snippet
'(delete-file-recursively "src"))))
- (properties `((upstream-name . "antiword")))
+ (properties
+ `((upstream-name . "antiword")
+ (updater-extra-inputs . ("antiword"))))
(build-system r-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'use-system-antiword
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "R/antiword.R"
- (("system.file\\(\"bin\", package = \"antiword\"\\)")
- (string-append "\"" (assoc-ref inputs "antiword") "/bin\""))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-system-antiword
+ (lambda _
+ (substitute* "R/antiword.R"
+ (("system.file\\(\"bin\", package = \"antiword\"\\)")
+ (string-append "\"" #$(this-package-input "antiword") "/bin\""))))))))
(inputs (list antiword))
(propagated-inputs (list r-sys))
(home-page "https://github.com/ropensci/antiword#readme")