summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:05:51 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:10:34 -0400
commit7d08b594952aa1b2a18bbb79888a6717e4691866 (patch)
treed2e56bec0b6000a0295bf17c0cb9e9ff6d5e3e28 /gnu
parent736d85bd2ffa2a6e649a77072b034bc47b465a18 (diff)
gnu: libxml2: Add $SGML_CATALOG_FILES to native-search-path.
According to the xmllint manpage it also makes use of the SGML_CATALOG_FILES environment variable. * gnu/packages/xml.scm (libxml2)[native-search-paths]: Add $SGML_CATALOG_FILES. Co-authored-by: gemmaro <gemmaro.dev@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I7b4befe352ba10b7a4e134f0806331b63bb4f855
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index baf024820c..16aabffca8 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -226,7 +226,8 @@ hierarchical form with variable field lengths.")
(inputs (list xz))
(propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
(native-inputs (list perl))
- (native-search-paths (list $XML_CATALOG_FILES))
+ (native-search-paths
+ (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
(search-paths native-search-paths)
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome