summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:09 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:16 -0500
commit80a18b617be58b6ca93acfd9e605932293d2c37b (patch)
treeabd42321f8478135a3b76a4c9faebddfde99b95e /gnu
parentcfe92d6ee17524f460295eb8dd9095ba7aee8375 (diff)
gnu: font-go: Install license files.
* gnu/packages/fonts.scm (font-go)[arguments]<#:license-file-regexp>: Add. <#:phases>: Add "enter-license-directory" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a95b4d4412..421df48a68 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2063,12 +2063,16 @@ and stylistic alternates.")
"1aq6mnjayks55gd9ahavk6jfydlq5lm4xm0xk4pd5sqa74p5p74d"))))
(build-system font-build-system)
(arguments
- `(#:phases
+ `(#:license-file-regexp "^(LICENSE|PATENTS)$"
+ #:phases
(modify-phases %standard-phases
(add-before 'install 'chdir
(lambda _
(chdir "font/gofont/ttfs")
- #t)))))
+ #t))
+ (add-before 'install-license-files 'enter-license-directory
+ (lambda _
+ (chdir "../../.."))))))
(home-page "https://blog.golang.org/go-fonts")
(synopsis "The Go font family")
(description