summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:03 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:10:56 -0400
commit80b59579b18fe7e315fe774a25700bee393231c1 (patch)
treebbed75939afdcc57d74590863a109871c8eb6c52 /gnu
parent350fe414d87415ad59a7509087752fb815773123 (diff)
gnu: docbook2x: Set search-paths for XML and SGML catalogs.
According to the manpage, it has both XML and SGML catalog support through the XML_CATALOG_FILES (resp. SGML_CATALOG_FILES) environment variables through db2x_xsltproc. * gnu/packages/docbook.scm (docbook2x)[arguments]<#:phases>: Don't hardcode XML_CATALOG_FILES environmment variable. [native-search-paths]: Add %libxslt-search-paths. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docbook.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 25761c5e5a..8c5cc74ab9 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages xfig)
#:use-module (gnu packages xml)
#:use-module (guix gexp)
+ #:use-module (guix search-paths)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -910,14 +911,10 @@ Detect the differences in markup between two SGML files.
'("perl-xml-namespacesupport"
"perl-xml-parser"
"perl-xml-sax"
- "perl-xml-sax-base")))
- (xml-catalog-files
- (list (search-input-file
- inputs "xml/dtd/docbook/catalog.xml"))))
+ "perl-xml-sax-base"))))
(map (lambda (program)
(wrap-program program
- `("PERL5LIB" ":" prefix ,perl5lib)
- `("XML_CATALOG_FILES" " " prefix ,xml-catalog-files)))
+ `("PERL5LIB" ":" prefix ,perl5lib)))
programs))))
(add-after 'install 'sgml-check
;; This is not covered by 'make check'.
@@ -950,6 +947,7 @@ Detect the differences in markup between two SGML files.
;; For tests
docbook-xml-4.1.2 docbook-xml-4.2 docbook-xml-4.4
groff-minimal libxml2))
+ (native-search-paths %libxslt-search-paths)
(home-page "https://docbook2x.sourceforge.net")
(synopsis "Convert DocBook to man page and Texinfo format")
(description