summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-04 16:11:38 -0400
committerMark H Weaver <mhw@netris.org>2014-08-04 16:12:44 -0400
commit82fce926f4fa685cc5f2512504fcb4c12c15b554 (patch)
tree317dad9dd32ff37cc9ade6a29d68762925016fe1 /gnu
parentfe138965afc89b905cac93195d7d96184dc08f26 (diff)
gnu: ffmpeg and vlc: Rely on runtime cpu detection.
* gnu/packages/video.scm (ffmpeg): Pass "--enable-runtime-cpudetect" to configure. Do not disable use of processor features that can be detected at runtime. (vlc): Rely on runtime cpu detection. Do not disable use of processor features that can be detected at runtime.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm34
1 files changed, 5 insertions, 29 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2516377a8e..4e22542afd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -170,31 +170,11 @@
"--enable-libtheora"
"--enable-libvorbis"
"--enable-libvpx"
- ;; drop special machine instructions not supported
- ;; on all instances of the target
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '()
- '("--disable-amd3dnow"
- "--disable-amd3dnowext"
- "--disable-mmx"
- "--disable-mmxext"
- "--disable-sse"
- "--disable-sse2"))
- "--disable-altivec"
- "--disable-sse3"
- "--disable-ssse3"
- "--disable-sse4"
- "--disable-sse42"
- "--disable-avx"
- "--disable-fma4"
- "--disable-avx2"
- "--disable-armv5te"
- "--disable-armv6"
- "--disable-armv6t2"
- "--disable-vfp"
- "--disable-neon"
+
+ "--enable-runtime-cpudetect"
+
+ ;; Runtime cpu detection is not implemented on
+ ;; MIPS, so we disable some features.
"--disable-mips32r2"
"--disable-mipsdspr1"
"--disable-mipsdspr2"
@@ -270,10 +250,6 @@ audio/video codec library.")
(arguments
`(#:configure-flags
`("--disable-a52" ; FIXME: reenable once available
- "--disable-mmx" ; FIXME: may be enabled on x86_64
- "--disable-sse" ; 1-4, no separate options available
- "--disable-neon"
- "--disable-altivec"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")))) ; needed for the tests