summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-28 08:23:38 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:59 +0100
commit840f23c3a0131ec22b58179cebf18cceb11b5cf1 (patch)
tree242e23ade199930224f202d53e60ec7db227f91b /gnu
parente0a1fcb1d183153c65143afa3e645dcf5433a9ba (diff)
gnu: ruby-hoe: Fix build.
* gnu/packages/ruby.scm (ruby-hoe)[arguments]: Update style and set #:tests? #f to work around a circular dependency.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f274676752..9fafe9a616 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -393,23 +393,9 @@ a menu system for providing multiple options to the user.")
"0r2hy7mq9jd9hsbvskd9sxfbagc92adnn7abzxbda05sscbf46hn"))))
(build-system ruby-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- ;; One of the tests fails if the SOURCE_DATE_EPOCH environment
- ;; variable is set, so unset it for the duration of the tests.
- ;;
- ;; TestHoe#test_possibly_better
- ;; [/tmp/guix-build-ruby-hoe-3.20.0.drv-0/gem/test/test_hoe.rb:250]:
- ;; Expected: 2019-11-12 00:00:00 UTC
- ;; Actual: 1970-01-01 00:00:00 UTC
- (add-before 'check 'unset-SOURCE-DATE-EPOCH
- (lambda _
- (unsetenv "SOURCE_DATE_EPOCH")
- #t))
- (add-after 'check 'set-SOURCE-DATE-EPOCH-again
- (lambda _
- (setenv "SOURCE_DATE_EPOCH" "1")
- #t)))))
+ (list
+ ;; Circular dependency with minitest
+ #:tests? #f))
(synopsis "Ruby project management helper")
(description
"Hoe is a rake/rubygems helper for project Rakefiles. It helps manage,