summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:41:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:56 +0200
commit89e1c9c22e7a4a539ad15ea2adeebfdfdab26517 (patch)
treecc74724f4c566897287a088f7ee3e635212462de /gnu
parent2bc85d9380b479b8d5b3dbea7c4ce8d527c0c075 (diff)
gnu: Add texlive-dtxgen.
* gnu/packages/tex.scm (texlive-dtxgen): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c52903dcbb..db6cb7800e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1661,6 +1661,26 @@ which is readily readable by humans. The DTL bundle contains an assembler
@command{dv2dt}, which produces DTL files from DVI files.")
(license license:public-domain)))
+(define-public texlive-dtxgen
+ (package
+ (name "texlive-dtxgen")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/dtxgen/" "scripts/dtxgen/")
+ (base32
+ "1j1j136p4ddjlmwmhwlpmsxqpx2ixhhssfsl8l49lds80ad4y98m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "dtxgen")))
+ (home-page "https://ctan.org/pkg/dtxgen")
+ (synopsis "Creates a template for a self-extracting @file{.dtx} file")
+ (description
+ "The Bash script dtxgen creates a template for a self-extracting
+@file{.dtx} file. It is useful for those who plan to create a new documented
+LaTeX source (.dtx) file.")
+ (license license:gpl3+)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")