summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:34 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:11:02 -0400
commit89fbb967a6a9b1a06416eee296190a742020098c (patch)
treed6ffc003e16be11b168a77546e7150a98daed2d9 /gnu
parent2add52ac120777bf4bd77930098b41c8d31baae2 (diff)
gnu: iputils: Restyle description and native-inputs.
* gnu/packages/networking.scm (iputils)[native-inputs]: Reorder inputs. [description]: Use @table over @itemize. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e9e5bf1c75..c97995d259 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1628,28 +1628,36 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
(("if build_ping == true")
"if false")))))))
(native-inputs
- (list gettext-minimal
- pkg-config
- docbook-xsl
- docbook-xml-5.0.1
- libxml2 ;for XML_CATALOG_FILES
- libxslt))
+ (list docbook-xsl docbook-xml-5.0.1
+ gettext-minimal
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt pkg-config))
(inputs
(list libcap libidn2 openssl))
(synopsis "Collection of network utilities")
(description
"This package contains a variety of tools for dealing with network
configuration, troubleshooting, or servers. Utilities included are:
-
-@itemize @bullet
-@item @command{arping}: Ping hosts using the @dfn{Address Resolution Protocol}.
-@item @command{clockdiff}: Compute time difference between network hosts
-using ICMP TSTAMP messages.
-@item @command{ping}: Use ICMP ECHO messages to measure round-trip delays
-and packet loss across network paths.
-@item @command{tracepath}: Trace network path to an IPv4 or IPv6 address and
-discover MTU along the way.
-@end itemize")
+@table @command
+@item arping
+Ping hosts using @acronym{ARP, Address Resolution Protocol}.
+@item clockdiff
+Compute time difference between network hosts using ICMP TSTAMP messages.
+@item ninfod
+Daemon that responds to IPv6 Node Information Queries.
+@item ping
+Use ICMP ECHO messages to measure round-trip delays and packet loss across
+network paths.
+@item rarpd
+Answer RARP requests from clients.
+@item rdisc
+Populate network routing tables with information from the ICMP router
+discovery protocol.
+@item tftpd
+Trivial file transfer protocol server.
+@item tracepath
+Trace network path to an IPv4 or IPv6 address and discover MTU along the way.
+@end table")
;; The various utilities are covered by different licenses, see LICENSE
;; for details.
(license (list license:gpl2+ ;arping, tracepath