summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:07:13 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:19:12 +0200
commit8b38ecb5218b86910957bcd3e94eab784de2e0c4 (patch)
tree7e7b5628a446733522328b3d2a302776596475a1 /gnu
parentb0b556cba41f589eac026de7a042084fa4b2bc58 (diff)
gnu: python-cvxopt: Remove dependency on lapack.
* gnu/packages/maths.scm (python-cvxopt): Remove dependency on lapack. Change-Id: I2a28ecf1ab5ea7683d6b8adf72054d3f86892771 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a4c3ac9826..874eb8a6fd 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -402,6 +402,7 @@ triangulations.")
(add-after 'unpack 'find-libraries
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CVXOPT_BLAS_LIB" "openblas")
+ (setenv "CVXOPT_LAPACK_LIB" "openblas")
(setenv "CVXOPT_BUILD_FFTW" "1")
(setenv "CVXOPT_BUILD_GLPK" "1")
(setenv "CVXOPT_BUILD_GSL" "1")
@@ -410,7 +411,6 @@ triangulations.")
(list fftw
glpk
gsl
- lapack
openblas
suitesparse))
(home-page "https://www.cvxopt.org")