summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2024-01-06 18:24:56 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2024-01-08 13:55:39 +0300
commit9018c6af4907c4532a95017df9f45d9439c30064 (patch)
treea8c1a79bb7c569dc3d25a2d6d0a6b5258470c4b3 /gnu
parent728d471d73c3731b86cbf5f3dee22229d3a92d4b (diff)
gnu: obs: Fix VLC plugin.
* gnu/packages/video.scm (obs)[arguments]<#:phases>: Wrap LD_LIBRARY_PATH. Change-Id: If22b5294284ea500da0e6d9ee4d4bbcc765c6771
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4181013b0d..de812ac762 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3642,7 +3642,10 @@ be used for realtime video capture via Linux-specific APIs.")
(lambda* _
(let ((plugin-path (getenv "QT_PLUGIN_PATH")))
(wrap-program (string-append #$output "/bin/obs")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))
+ `("LD_LIBRARY_PATH" ":" prefix
+ (,(string-append #$(this-package-input "vlc")
+ "/lib"))))))))))
(native-search-paths
(list (search-path-specification
(variable "OBS_PLUGINS_DIRECTORY")