summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-20 14:14:17 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-26 17:06:17 +0200
commit94b7e9b7b4d03a5dd42b6514c346062ea0f198a1 (patch)
tree540cf6b5e061605cd15ff7ec78969a60e8a8a2b0 /gnu
parentc26c062838ac1a4f7cce9f6e4c8f0f8ada043c28 (diff)
gnu: Add r-tidyr.
* gnu/packages/statistics.scm (r-tidyr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 781620ca31..44553d54e4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2413,6 +2413,35 @@ black-and-white. They are also designed to be perceived by readers with the
most common form of color blindness.")
(license license:x11)))
+(define-public r-tidyr
+ (package
+ (name "r-tidyr")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyr" version))
+ (sha256
+ (base32
+ "0xp6lyr2l4ix2mrilx4qmca7wm5qmbhvi24m4nf7qsgwp54gnv2h"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-stringi" ,r-stringi)))
+ (home-page "https://github.com/hadley/tidyr")
+ (synopsis "Tidy data with `spread()` and `gather()` functions")
+ (description
+ "tidyr is a reframing of the reshape2 package designed to accompany the
+tidy data framework, and to work hand-in-hand with magrittr and dplyr to build
+a solid pipeline for data analysis. It is designed specifically for tidying
+data, not the general reshaping that reshape2 does, or the general aggregation
+that reshape did. In particular, built-in methods only work for data frames,
+and tidyr provides no margins or aggregation.")
+ (license license:expat)))
+
(define-public r-plotly
(package
(name "r-plotly")