summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-04-10 20:46:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-04-10 20:49:33 +0300
commit96a132809f0196d6a08f6c5c6900846d9859beb2 (patch)
tree35f0540c0cc01105f155a1c3b2b96de2097a7719 /gnu
parent81567f751bd31d972cf05013a177311b73425d7d (diff)
gnu: smithwaterman: Fix cross-compiling.
The 'ar' matched the 'ar' in 'aarch64-linux-gnu' to unfun consequences. * gnu/packages/bioinformatics.scm (smithwaterman)[arguments]: More closely match the 'ar' and 'ld' commands when substituting them.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 106b25a50b..0755b035e6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14230,8 +14230,10 @@ some of the details of opening and jumping in tabix-indexed files.")
(("-c ") "-c -fPIC "))
#$@(if (%current-target-system)
#~((substitute* "Makefile"
- (("ld") (string-append #$(%current-target-system) "-ld"))
- (("ar") (string-append #$(%current-target-system) "-ar"))))
+ (("\tld")
+ (string-append "\t" #$(%current-target-system) "-ld"))
+ (("\tar")
+ (string-append "\t" #$(%current-target-system) "-ar"))))
'())))
(add-after 'build 'build-dynamic
(lambda _