summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:44:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:19:01 +0200
commit9da7433cc7d7919faa03bac7b1bf817c15d1ef22 (patch)
tree4afe5f7df3bfca3197829e240c9634e19c60f438 /gnu
parentd63b8ed17d59dd4b3f7b064c89f31869e9b51367 (diff)
gnu: Add texlive-fragmaster.
* gnu/packages/tex.scm (texlive-fragmaster): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1d91ff377c..d10c5f0291 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2029,6 +2029,28 @@ generates a VF file and a TFM file; @command{vftovp} takes a VF file and a TFM
file and generates a VPL file.")
(license license:knuth)))
+(define-public texlive-fragmaster
+ (package
+ (name "texlive-fragmaster")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/fragmaster/"
+ "scripts/fragmaster/")
+ (base32
+ "1vwbkbg96dql73gayb06gs2fdxynljibjkmhliglc9ddggyx4v2m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "fragmaster.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/fragmaster")
+ (synopsis "Using @command{psfrag} with pdfLaTeX")
+ (description
+ "Fragmaster enables you to use @command{psfrag} with pdfLaTeX. It takes
+EPS files and @command{psfrag} substitution definition files, and produces PDF
+and EPS files with the substitutions included.")
+ (license license:gpl3+)))
+
(define-public texlive-tex
(package
(name "texlive-tex")