summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-21 10:05:53 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:55 +0100
commit9dad3618cc1c97f37c9a33ae9fbf6de88efcce3a (patch)
treedeca1a86795f6710565c862f6c320bc4a2a69a75 /gnu
parent191109ccff133d66f93fc3bfad2180aa8c266a97 (diff)
gnu: ruby-bindex: Update to 0.8.1 and rename to ruby-skiptrace.
* gnu/packages/ruby.scm (ruby-bindex): Update to 0.8.1 and rename to ruby-skiptrace. [arguments]: Update style, remove git dependency and replace check phase. [description,home-page]: Update for rename. * gnu/packages/rails.scm (ruby-web-console)[propagated-inputs]: Replace ruby-bindex with ruby-skiptrace.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rails.scm2
-rw-r--r--gnu/packages/ruby.scm26
2 files changed, 19 insertions, 9 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index 9709121a19..87ac5def12 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -1426,7 +1426,7 @@ Stimulus can be used.")
;; needs to be in the Gemfile to become available.
(("group :test do") "group :test do\n gem 'tzinfo-data'")))))))
(propagated-inputs
- (list ruby-actionview ruby-activemodel ruby-arel ruby-bindex ruby-railties))
+ (list ruby-actionview ruby-activemodel ruby-arel ruby-skiptrace ruby-railties))
(native-inputs
(list bundler ruby-rails ruby-mocha ruby-simplecov))
(synopsis "Debugging tool for your Ruby on Rails applications")
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 90827e048d..af576e9b78 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9852,28 +9852,38 @@ is an infix boolean expression used by Cucumber.")
(home-page "https://github.com/cucumber/tag-expressions")
(license license:expat)))
-(define-public ruby-bindex
+(define-public ruby-skiptrace
(package
- (name "ruby-bindex")
- (version "0.5.0")
+ (name "ruby-skiptrace")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
- (uri (rubygems-uri "bindex" version))
+ (uri (rubygems-uri "skiptrace" version))
(sha256
(base32
- "1wvhf4v8sk5x8li03pcc0v0wglmyv7ikvvg05bnms83dfy7s4k8i"))))
+ "1qpjy6pqd8hx4w7bai64jsr10mwbpnnb65wcbssyqcnalimi1s12"))))
(build-system ruby-build-system)
(arguments
- '(#:test-target "default"))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-git-from-gemspec
+ (lambda _
+ (substitute* "skiptrace.gemspec"
+ (("`git ls-files -z`") "`find . -type f -print0 |sort -z`"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "bundle" "exec" "rake" "default")))))))
(native-inputs
(list bundler ruby-rake-compiler))
(synopsis "Provides access for bindings relating to Ruby exceptions")
(description
- "@code{bindex} provides a way to access the bindings that relate to
+ "@code{skiptrace} provides a way to access the bindings that relate to
exceptions in Ruby, providing more information about the context in which the
exception occurred.")
- (home-page "https://github.com/gsamokovarov/bindex")
+ (home-page "https://github.com/gsamokovarov/skiptrace")
(license license:expat)))
(define-public ruby-bio-logger