summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-08 17:11:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-08 17:11:42 +0300
commita134cc8e93428bf6f309de54e5c944705d30418f (patch)
tree6d55203cb0e3b1e675194b3b183f10d77cba887d /gnu
parentdae620b8fe83bada3e83579c1a02e2bac45adfef (diff)
gnu: vlc: Update to 2.2.4 [fixes CVE-2016-5108].
* gnu/packages/video.scm (vlc): Update to 2.2.4. [inputs]: Remove qt, add qtbase. [arguments]: Add phase to disable display test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index eae7f64d85..692f3645e6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -559,15 +559,15 @@ audio/video codec library.")
(define-public vlc
(package
(name "vlc")
- (version "2.2.1")
+ (version "2.2.4")
(source (origin
(method url-fetch)
(uri (string-append
- "http://download.videolan.org/pub/videolan/vlc/"
+ "https://download.videolan.org/pub/videolan/vlc/"
version "/vlc-" version ".tar.xz"))
(sha256
(base32
- "1jqzrzrpw6932lbkf863xk8cfmn4z2ngbxz7w8ggmh4f6xz9sgal"))
+ "1gjkrwlg8ab3skzl67cxb9qzg4187ifckd1z9kpy11q058fyjchn"))
(modules '((guix build utils)))
(snippet
;; There are two occurrences where __DATE__ and __TIME__ are
@@ -609,7 +609,8 @@ audio/video codec library.")
("perl" ,perl)
("pulseaudio" ,pulseaudio)
("python" ,python-wrapper)
- ("qt" ,qt)
+ ("qtbase" ,qtbase)
+ ;("qtx11extras" ,qtx11extras)
("sdl" ,sdl)
("sdl-image" ,sdl-image)
("speex" ,speex)
@@ -623,6 +624,13 @@ audio/video codec library.")
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'remove-visual-tests
+ ;; Some of the tests require using the display to test out VLC,
+ ;; which fails in our sandboxed build system
+ (lambda _
+ (substitute* "test/run_vlc.sh"
+ (("./vlc --ignore-config") "echo"))
+ #t))
(add-after 'install 'regenerate-plugin-cache
(lambda* (#:key outputs #:allow-other-keys)
;; The 'install-exec-hook' rule in the top-level Makefile.am