summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-11-06 00:51:47 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-23 12:56:43 +0100
commita4d7310ab97e45166ea845deb574cc4efbd1b915 (patch)
treef266c684037ee90d2fae431a71b6aedea135ef5b /gnu
parent70b1ac2bc56d57565d3c0cae6d62588cefd35bb3 (diff)
gnu: scilab: Add phase rewrap-scilab-cli.
* gnu/packages/maths.scm (scilab): Add phase rewrap-scilab-cli. Change-Id: Ia3ca5df1a4795c34b6c1cdc8c3b0d7cc2badf0cb Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index abc0dc748d..9113e2e28d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9708,7 +9708,27 @@ computation is supported via MPI.")
(apply invoke "make"
"src/cpp/parse/parsescilab.cpp"
"src/cpp/parse/scanscilab.cpp"
- make-flags))))))))
+ make-flags))))
+ ;; The startup script is mostly there to define the following env
+ ;; variables properly. We can do this with guix directly.
+ (add-after 'install 'rewrap-scilab-cli
+ (lambda _
+ (define (bin path) (string-append #$output "/bin/" path))
+ (delete-file (bin "scilab-cli"))
+ (wrap-program (bin "scilab-cli-bin")
+ `("SCI" = (,(string-append #$output "/share/scilab")))
+ `("LD_LIBRARY_PATH" ":" prefix
+ (,(string-append #$output "/lib/scilab")))
+ `("TCL_LIBRARY" = (,(string-append #$tcl "/lib")))
+ `("TK_LIBRARY" = (,(string-append #$tk "/lib"))))
+ (copy-file (bin "scilab-cli-bin") (bin "scilab-cli"))
+ (copy-file (bin ".scilab-cli-bin-real") (bin "scilab-cli-bin"))
+ (delete-file (bin ".scilab-cli-bin-real"))
+ (substitute* (bin "scilab-cli")
+ (("\\.scilab-cli-bin-real")
+ "scilab-cli-bin")
+ (("export SCI=")
+ "unset LANGUAGE\nexport SCI="))))))))
(home-page "https://www.scilab.org/")
(synopsis "Software for engineers and scientists")
(description "This package provides the non-graphical version of the Scilab