summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:17:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:22 +0200
commita4dc8edcedb98fa37224b287e24260ac4946a86d (patch)
treecc1b2f9aac187264a416a7e8dbbc2013acc07afb /gnu
parent9cf4d488501d38d13c458669f15588555912f089 (diff)
gnu: Add r-beaddatapackr.
* gnu/packages/bioconductor.scm (r-beaddatapackr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8f0c3759d7..d8ce480486 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -19283,6 +19283,26 @@ matrices.")
performs copy number calculations and reports.")
(license license:gpl2)))
+(define-public r-beaddatapackr
+ (package
+ (name "r-beaddatapackr")
+ (version "1.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BeadDataPackR" version))
+ (sha256
+ (base32
+ "0hm4brxg2rxazdcnhjiz6f4di2q8wssrrp35m79vm93sac9w42y3"))))
+ (properties `((upstream-name . "BeadDataPackR")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/BeadDataPackR")
+ (synopsis "Compression of Illumina BeadArray data")
+ (description
+ "This package provides functionality for the compression and
+decompression of raw bead-level data from the Illumina BeadArray platform.")
+ (license license:gpl2)))
+
;; This package includes files that have been taken from kentutils. Some
;; parts of kentutils are not released under a free license, but this package
;; only uses files that are also found in the free parts of kentutils.