summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 16:29:53 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-29 12:13:07 +0100
commita7ac67b58dd09a356fc67a9660af864759ff1958 (patch)
treee2db0b00544624e31eb3878c022d055455e0b637 /gnu
parent03e908bf781b59275a7ff5799df27c13194be1f7 (diff)
gnu: Add texlive-dvicopy-bin.
* gnu/packages/tex.scm (texlive-dvicopy-bin): New variable. (texlive-dvicopy)[propagated-inputs]: Add TEXLIVE-DVICOPY-BIN. Change-Id: Ib0016bbda64c7a1cb7d062b034e73acaa3c28582
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a79930c3b4..b641ae16f2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34042,6 +34042,7 @@ or watermarks.")
"010bs4iyaja7mq5wy9mz6fzxlxf9472c2zdm93x9i474dzgnh2vl")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-dvicopy-bin))
(home-page "https://ctan.org/pkg/dvicopy")
(synopsis "Copy DVI files, flattening VFs")
(description
@@ -34051,6 +34052,29 @@ does not contain such references. It also serves as a basis for writing DVI
drivers (much like DVItype).")
(license license:gpl3+)))
+(define-public texlive-dvicopy-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-dvicopy-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(delete "--enable-web2c" #$flags))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (invoke "make" "dvicopy")
+ (install-file "dvicopy"
+ (string-append #$output "/bin")))))))))
+ (native-inputs (list pkg-config))
+ (home-page (package-home-page texlive-dvicopy))
+ (synopsis "Binary for @code{texlive-dvicopy}")
+ (description
+ "This package provides the binary for @code{texlive-dvicopy}.")
+ (license (package-license texlive-dvicopy))))
+
(define-public texlive-dvidvi
(package
(name "texlive-dvidvi")