summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2024-02-11 19:28:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:22 +0000
commita90bc5030d948343f0e4791057f568ce8f2d1dfc (patch)
treef35176ba62494d0e0c0971d974a2255971dcc4f0 /gnu
parent3fa6971f2c6e3d796b18fd01cba2d062d63ffe93 (diff)
gnu: Add go-github-com-cyberdelia-go-metrics-graphite.
* gnu/packages/golang-xyz.scm (go-github-com-cyberdelia-go-metrics-graphite): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Id77785387b23a8317b21c2a7f7114f1c1aa6328b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3b69c8fb36..dafbbfea30 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -82,6 +82,32 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-cyberdelia-go-metrics-graphite
+ (package
+ (name "go-github-com-cyberdelia-go-metrics-graphite")
+ (version "0.0.0-20161219230853-39f87cc3b432")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cyberdelia/go-metrics-graphite")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nnpwryw8i110laffyavvhx38gcd1jnpdir69y6fxxzpx06d094w"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ (list go-github-com-rcrowley-go-metrics))
+ (arguments
+ '(#:tests? #f ; Tests require network interface access
+ #:import-path "github.com/cyberdelia/go-metrics-graphite"))
+ (home-page "https://github.com/cyberdelia/go-metrics-graphite")
+ (synopsis "Graphite client for go-metrics")
+ (description "This package provides a reporter for the
+@url{https://github.com/rcrowley/go-metrics,go-metrics} library which posts
+metrics to Graphite.")
+ (license license:bsd-2)))
+
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")