summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-09 23:10:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-10 00:16:56 +0300
commita9c958b5aa55a729a1530b2e23e088bb982f696c (patch)
tree6ffb77bfd412a57947e16dc0a50f98de847c16f0 /gnu
parentfedcb99d840265824ebf7c5631c609b86560fc44 (diff)
gnu: gcj: Switch dejagnu test command.
* gnu/packages/gcc.scm (gcj)[arguments]: Switch the depreciated dejagnu command 'absolute' for the new testing command 'file normalize'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 3880cab52b..c961c84fca 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -559,6 +559,13 @@ as the 'native-search-paths' field."
(("libgcj(_bc)?_la_LDFLAGS =" ldflags _)
(string-append ldflags " -Wl,-rpath=$(libdir)")))))
(add-after
+ 'unpack 'patch-testsuite
+ ;; dejagnu-1.6 removes the 'absolute' command
+ (lambda _
+ (substitute* "libjava/testsuite/lib/libjava.exp"
+ (("absolute") "file normalize"))
+ #t))
+ (add-after
'install 'install-javac-and-javap-wrappers
(lambda _
(let* ((javac (assoc-ref %build-inputs "javac.in"))