summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-01-17 14:18:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-22 09:16:18 +0100
commitac32f93df36f1908c3d90c28704e3b2bf9c91c36 (patch)
treebad6b910965f8b1709140b29cd775296df7f2f86 /gnu
parent452039f35ebb7cb2db8d3bb706d06743442e11c3 (diff)
gnu: Add r-anvil.
* gnu/packages/bioconductor.scm (r-anvil): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 420940ff21..711b988e7f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2464,6 +2464,47 @@ Powerful interactive and dynamic figures generated by animalcules enable users
to understand their data better and discover new insights.")
(license license:artistic2.0)))
+(define-public r-anvil
+ (package
+ (name "r-anvil")
+ (version "1.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnVIL" version))
+ (sha256
+ (base32
+ "0iqsffkrxv28g9cddx2w05f2dbscwxhh6bpizwa8xaxhvn5bcpsv"))))
+ (properties `((upstream-name . "AnVIL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocmanager
+ r-dplyr
+ r-dt
+ r-futile-logger
+ r-htmltools
+ r-httr
+ r-jsonlite
+ r-miniui
+ r-rapiclient
+ r-rlang
+ r-shiny
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AnVIL")
+ (synopsis "Provides access to AnVIL, Terra, Leonardo and other projects")
+ (description
+ "The AnVIL is a cloud computing resource developed in part by the
+National Human Genome Research Institute. The AnVIL package provides end-user
+and developer functionality. AnVIL provides fast binary package installation,
+utilities for working with Terra/AnVIL table and data resources, and
+convenient functions for file movement to and from Google cloud storage. For
+developers, AnVIL provides programatic access to the Terra, Leonardo, Rawls,
+Dockstore, and Gen3 RESTful programming interface, including helper functions
+to transform JSON responses to formats more amenable to manipulation in R.")
+ (license license:artistic2.0)))
+
(define-public r-aldex2
(package
(name "r-aldex2")