summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:18:23 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 21:57:31 +0000
commitae1c3ce8dcdbf12bc13926a945160f71461291ab (patch)
tree6e55a7e6d710fe89400800e4e32c46f17bde00a5 /gnu
parentd67e4f0f9b10c7ddac8fb0ca68cbf1d6ad0a6e5d (diff)
gnu: cl-form-types: Disable tests on ECL implementation.
* gnu/packages/lisp-xyz.scm (ecl-cl-form-types): Disable tests. Change-Id: I8cca905edc57bf4e3e25847aff425ef1762f2e3f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 012a62526f..fa462ca16d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16693,7 +16693,15 @@ Macros and symbol-macros are fully expanded and all special forms, except
(sbcl-package->cl-source-package sbcl-cl-form-types))
(define-public ecl-cl-form-types
- (sbcl-package->ecl-package sbcl-cl-form-types))
+ (let ((pkg (sbcl-package->ecl-package sbcl-cl-form-types)))
+ (package
+ (inherit pkg)
+ (arguments
+ ;; FIXME: Syntax error in declaration (TYPE T (FORM &KEY STRICT
+ ;; EXPAND-COMPILER-MACROS (TEST (QUOTE FORM-TYPE=))))
+ ;; An error occurred during initialization: COMPILE-FILE-ERROR while...
+ ;; See <https://github.com/alex-gutev/cl-form-types/issues/22>.
+ '(#:tests? #f)))))
(define-public sbcl-generic-cl
(package