summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-04 13:15:40 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-05 12:38:48 -0400
commitae64112828824895957038842fb705e846e3b69c (patch)
treed8059733aa9a8be3ad8b8b7cd3ad8f514afb045b /gnu
parent121398e7d4e78fbecb1ad56b7b853523b5a492fa (diff)
gnu: python-requests: Fix Python 2 version and add support for Python 3.
* gnu/packages/python.scm (python-requests): New variable. (python2-requests): Generate based on Python 3 variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c5cae6de45..8c86d5a768 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1571,9 +1571,9 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python2-certifi
(package-with-python2 python-certifi))
-(define-public python2-requests
+(define-public python-requests
(package
- (name "python2-requests")
+ (name "python-requests")
(version "2.4.0")
(source (origin
(method url-fetch)
@@ -1588,8 +1588,7 @@ is used by the Requests library to verify HTTPS requests.")
(inputs
`(("python-setuptools" ,python-setuptools)
("python-certifi" ,python-certifi)))
- (arguments `(#:tests? #f ; no tests
- #:python ,python-2))
+ (arguments `(#:tests? #f)) ; no tests
(home-page "http://python-requests.org/")
(synopsis "Python HTTP library")
(description
@@ -1597,6 +1596,9 @@ is used by the Requests library to verify HTTPS requests.")
than Python’s urllib2 library.")
(license asl2.0)))
+(define-public python2-requests
+ (package-with-python2 python-requests))
+
(define-public python-jsonschema
(package
(name "python-jsonschema")