summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:10:33 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:57 -0400
commitb387f1ae9187e61b813fb7bad13333aa2aef2053 (patch)
treecd662efb21eb9f3eb8c6c66fbffd2b93b46eab01 /gnu
parentd23ba0123666f224be6906e66dc37ad5fca1eff0 (diff)
gnu: Add texlive-xpinyin.
* gnu/packages/tex.scm (texlive-xpinyin): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2999084f02..da0ef4426e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23111,6 +23111,25 @@ names, as well as character data, may use any characters allowed in XML, using
UTF-8 or a suitable 8-bit encoding.")
(license license:lppl1.0+))) ;per xmltex/base/readme.txt
+(define-public texlive-xpinyin
+ (package
+ (name "texlive-xpinyin")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xpinyin/" "source/latex/xpinyin/"
+ "tex/latex/xpinyin/")
+ (base32
+ "1fxsnvmkm66rfq08j03sch24maw0wgb8dhl73r2rf6gwxzf4imc5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xpinyin")
+ (synopsis "Automatically add pinyin to Chinese characters")
+ (description
+ "The package is written to simplify the input of Hanyu Pinyin. Macros are
+provided that automatically add pinyin to Chinese characters.")
+ (license license:lppl1.3c)))
+
(define-public texlive-hyperref
(package
(name "texlive-hyperref")