summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 20:59:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:19:05 +0000
commitb41a40564929f40ed3541c8ce740362b3d13de70 (patch)
tree58e054c54e0f66d3640a9f40d54dc4618afe2b6e /gnu
parenta4aac98bbb6e6475ba7e35ad0eb82d861e483709 (diff)
gnu: go-github-com-mreiferson-go-svc: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mreiferson-go-svc): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I21f1d5f651fb09a3716cbcdb48aaf7f8dd37384d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 764a894a63..27b9043929 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -272,6 +272,34 @@ presenting a small interface.")
command line flags, config files, and default struct values.")
(license license:expat)))
+(define-public go-github-com-mreiferson-go-svc
+ ;; NSQ specific fork of github.com/judwhite/go-svc, as Guix go build system
+ ;; does not support go.mod with `replace' statement.
+ (let ((commit "7a96e00010f68d9436e3de53a70c53f209a0c244")
+ (revision "0"))
+ (package
+ (name "go-github-com-mreiferson-go-svc")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mreiferson/go-svc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1acgb0n3svhnraqj1fz5qc5n3b4vc5ffwyk9vfi6gcfkibm0hgmd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/judwhite/go-svc"))
+ (propagated-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/mreiferson/go-svc")
+ (synopsis "Go Windows Service wrapper for GNU/Linux")
+ (description
+ "Go Windows Service wrapper compatible with GNU/Linux. Windows tests
+@url{https://github.com/judwhite/go-svc/raw/master/svc/svc_windows_test.go,here}.")
+ (license license:expat))))
+
(define-public go-github-com-nats-io-nats-go
(package
(name "go-github-com-nats-io-nats-go")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4eb20e13f1..24c845c7b8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5485,34 +5485,6 @@ trivial @command{big.Int} encoding benchmark results in 6 times faster
encoding and 8 times faster decoding.")
(license license:expat))))
-(define-public go-github-com-mreiferson-go-svc
- ;; NSQ specific fork of github.com/judwhite/go-svc, as Guix go build system
- ;; does not support go.mod with `replace' statement.
- (let ((commit "7a96e00010f68d9436e3de53a70c53f209a0c244")
- (revision "0"))
- (package
- (name "go-github-com-mreiferson-go-svc")
- (version (git-version "1.2.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mreiferson/go-svc")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1acgb0n3svhnraqj1fz5qc5n3b4vc5ffwyk9vfi6gcfkibm0hgmd"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/judwhite/go-svc"))
- (propagated-inputs (list go-golang-org-x-sys))
- (home-page "https://github.com/mreiferson/go-svc")
- (synopsis "Go Windows Service wrapper for GNU/Linux")
- (description
- "Go Windows Service wrapper compatible with GNU/Linux. Windows tests
-@url{https://github.com/judwhite/go-svc/raw/master/svc/svc_windows_test.go,here}.")
- (license license:expat))))
-
(define-public go-github-com-spaolacci-murmur3
(package
(name "go-github-com-spaolacci-murmur3")