summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Desfosses <rdes@protonmail.com>2020-12-07 18:26:46 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-12-08 07:59:24 +0300
commitb5e52d8225e3e4f3124eb761eb3f2c1cad767166 (patch)
tree31888b713fe866faa3889a2373cf31db50a6489c /gnu
parentfedf7d57210b4a65dac6366b0897f1d69dc40423 (diff)
gnu: Add emacs-burly.
* gnu/packages/emacs-xyz.scm (emacs-burly): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5ee7ad906d..e2658b4547 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25743,3 +25743,28 @@ s-expression.")
work on alists, hash-table and arrays. All functions are prefixed with
@code{map-}.")
(license license:gpl3+)))
+
+(define-public emacs-burly
+ (package
+ (name "emacs-burly")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/burly.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vaikknjzmhpszyi4yxjjkp1ihgmhpbnbx1s5pjy4mnhl1ibi33b"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-map" ,emacs-map)))
+ (home-page "https://github.com/alphapapa/burly.el")
+ (synopsis "Save and restore frame/window configurations with buffers")
+ (description "This package provides tools to save and restore frame and
+window configurations in Emacs, including buffers that may not be live
+anymore. In this way, it's like a lightweight \"workspace\" manager, allowing
+you to easily restore one or more frames, including their windows, the
+windows' layout, and their buffers.")
+ (license license:gpl3+)))