summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-03-25 16:32:19 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-08 14:04:42 +0200
commitb818667188a5a80e5bb858a2b6c46b00e0fb69de (patch)
tree9a47b9fb98f89f8089ef095182b77c11db201f7e /gnu
parent3ede522d3dfcbd6b6f971e299e7059c5fe775ba7 (diff)
gnu: Add python-sentencepiece.
* gnu/packages/machine-learning.scm (python-sentencepiece): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 072fb1ab15..402a8226b5 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -611,6 +611,25 @@ SentencePiece allows us to make a purely end-to-end system that does not
depend on language-specific pre- or post-processing.")
(license license:asl2.0)))
+(define-public python-sentencepiece
+ (package
+ (name "python-sentencepiece")
+ (version "0.1.97")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sentencepiece" version))
+ (sha256
+ (base32 "0v0z9ryl66432zajp099bcbnwkkldzlpjvgnjv9bq2vi19g300f9"))))
+ (build-system python-build-system)
+ (native-inputs (list pkg-config))
+ (propagated-inputs (list sentencepiece))
+ (home-page "https://github.com/google/sentencepiece")
+ (synopsis "SentencePiece python wrapper")
+ (description "This package provides a Python wrapper for the SentencePiece
+unsupervised text tokenizer.")
+ (license license:asl2.0)))
+
(define-public shogun
(package
(name "shogun")