summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 13:50:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 14:37:03 +0100
commitbe9e8c3963b45c674a529c7461a4e7933c3efd93 (patch)
tree2a9cb717fa5c3ad30f0348924a4bf648596aa31e /gnu
parenta88fa1ced73ff320040e3dba58947f91aab6fa02 (diff)
gnu: Add python-apispec-webframeworks.
* gnu/packages/python-xyz.scm (python-apispec-webframeworks): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f0a7ef49f..d429a4a734 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20975,6 +20975,34 @@ while only declaring the test-specific fields.")
as Swagger.")
(license license:expat)))
+(define-public python-apispec-webframeworks
+ (package
+ (name "python-apispec-webframeworks")
+ (version "0.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "apispec-webframeworks" version))
+ (sha256
+ (base32
+ "1wyw30402xq2a8icrsjmy9v43jyvawcjd85ccb2zicqlg4k5pcqd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-apispec))
+ (native-inputs
+ (list python-bottle
+ python-flake8
+ python-flake8-bugbear
+ python-flask
+ python-mock
+ python-pre-commit
+ python-pytest
+ python-tornado
+ python-tox))
+ (home-page "https://github.com/marshmallow-code/apispec-webframeworks")
+ (synopsis "Web framework plugins for apispec")
+ (description "This package provides plugins for using @code{apispec} with
+web frameworks.")
+ (license license:expat)))
+
(define-public python-flasgger
(package
(name "python-flasgger")