summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-16 21:50:51 +0300
committerChristopher Baines <mail@cbaines.net>2024-06-29 12:00:13 +0100
commitc58403554dc4e50f66450d1cbd0f36585678a9c9 (patch)
treed16f3fa81f81596d555d074f949fb98f16d3a650 /gnu
parent0d76a02133bebdc6a584e24406aa94557cbf3a0c (diff)
gnu: make-libstdc++: Adjust order of phases.
* gnu/packages/gcc.scm (make-libstdc++)[arguments]: Move custom 'fix-rs6000-libdir phase to after the 'unpack phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1cefea8d1d..12b363738a 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -983,7 +983,7 @@ using compilers other than GCC."
(assoc-ref inputs "powerpc64le-patch"))))))
'()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
- (add-before 'chdir 'fix-rs6000-libdir
+ (add-after 'unpack 'fix-rs6000-libdir
(lambda _
(when (file-exists? "gcc/config/rs6000")
(substitute* (find-files "gcc/config/rs6000")