summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-29 19:59:45 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-13 22:26:38 -0500
commitc77978d6c8d28e34e656f5b22ae9f0927e2f2dec (patch)
tree3a6baa094dae408d66bba9a1204686e9bace7b0a /gnu
parent08b454f0e5a853907f21397fb5c214abddcd710a (diff)
gnu: Add fbgrab.
* gnu/packages/linux.scm (fbgrab): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 676a339a7d..3f6d7f45df 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -127,6 +127,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell-apps)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages llvm)
@@ -8461,6 +8462,38 @@ Also included is @command{fbgrab}, a wrapper around @command{fbcat} that
emulates the behaviour of Gunnar Monell's older fbgrab utility.")
(license license:gpl2)))
+(define-public fbgrab
+ (package
+ (name "fbgrab")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GunnarMonell/fbgrab")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1npn7l8jg0nhjraybjl38v8635zawzmn06ql3hs3vhci1vi1r90r"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "DESTDIR=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'strip-/usr-prefix
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr") ""))))
+ (delete 'configure))))
+ (inputs (list libpng zlib))
+ (home-page "https://github.com/GunnarMonell/fbgrab")
+ (synopsis "Linux framebuffer screenshot/conversion utility")
+ (description "FBGrab is a framebuffer screenshot program that captures the
+Linux framebuffer and converts it to a PNG image. It can also convert a
+framebuffer dump file (copy) to a PNG image.")
+ (license license:gpl2))) ;GPL 2.0 only (per SPDX identifier in fbgrab.c)
+
(define-public libcgroup
(package
(name "libcgroup")