summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:36:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:55 +0200
commitc79b6b6c5f6e4649a11a68143cc484af0c707359 (patch)
tree0d161fe86a1fc7add0fbeda9a0eeb145076847fb /gnu
parent8713eebf69d7da4e47d3a4cb98839f22646bd5ef (diff)
gnu: Add texlive-xindex.
* gnu/packages/tex.scm (texlive-xindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eb837a4c6e..57a7488beb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8407,6 +8407,25 @@ ordinary text, and as a picture element within a TikZ-picture. The appearance
of a flag (size, frame etc.) can be adapted using optional parameters.")
(license license:lppl1.3+)))
+(define-public texlive-xindex
+ (package
+ (name "texlive-xindex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/xindex/" "scripts/xindex/"
+ "tex/latex/xindex/" "tex/lualatex/xindex/")
+ (base32
+ "1zcfr6vxh49cwpqa594ibmjxs775z08l5pqz36w3013dzh6m3yh1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "xindex.lua")))
+ (home-page "https://ctan.org/pkg/xindex")
+ (synopsis "Unicode compatible index generation")
+ (description
+ "This package provides a Unicode compatible index programm for LaTeX.")
+ (license license:lppl1.3+)))
+
(define-public texlive-xistercian
(package
(name "texlive-xistercian")