summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@using.tech>2022-10-12 15:44:34 -0400
committerChristopher Baines <mail@cbaines.net>2022-10-16 18:15:03 +0100
commitcbaf47bb8b7cda6f6bb343d24866db03eb0445f7 (patch)
tree638840789c5b6e0c39ad93d6c12e585833c93b70 /gnu
parentfc68b97db12b34dec558fde73d651aa0d3bbd446 (diff)
gnu: Add python-dotmap
* gnu/packages/python-xyz.scm: New variable Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60ca7d1506..ad9204e461 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -496,6 +496,25 @@ and variables you'll need already imported and created.
(home-page "https://github.com/google/python-fire")
(license license:asl2.0)))
+(define-public python-dotmap
+ (package
+ (name "python-dotmap")
+ (version "1.3.30")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dotmap" version))
+ (sha256
+ (base32
+ "0s5kb2v7jd0narz6m6jcicak3h5pw290wz21cdsv8pq77y9sf8aq"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/drgrib/dotmap")
+ (synopsis "Ordered, dynamically-expandable dot-access dictionary")
+ (description
+ "DotMap is a dot-access dictionary subclass that has dynamic
+hierarchy creation, can be initialized with keys, can be initialized from a
+dictionary, can be convert to a dictionary, and is ordered by insertion.")
+ (license license:expat)))
+
(define-public python-twodict
(package
(name "python-twodict")